highlight (hl)

   

Home

Introduction

Features

Download

Screenshots

FAQ

Installation

Userguide

Contact

 

 

SourceForge.net Logo

   
     

download

Requirements (what you need):

'hl' is written in C++. So the first thing you must have is a C++-compiler such as for example 'gcc' which is available under the terms of the GNU Public License (i.e. you can use and redistribute it freely as long as you do not sell it, for further details check the lawyers stuff in the license).
Next you need a UN*X operating system such as Linux or Solaris with colored terminal capabilities.
Needed libraries:
  • ncurses - this is the standard library for advanced terminal applications. If you can run 'top' on your system it will work.
  • pthread - this it the POSIX thread library (Linux/Solaris systems should have them)

License & Download:

License:
This software is available under the terms of the GNU Public License.
This means you can freely use, change, redistribute the codes as long as you don't charge money for the code itself.  For further details check the link above or read the COPYING file included in the download package.
Download:
Here you can download the latest version of highlight.
If you don't like to compile it yourself you can select the precomlide binary version (only for x86 computers).
 
 
sources for highlight 0.32:  highlight-032.tar.gz
sources + x86 binaries:  highlight-0.32binx86.tar.gz

Copyright © 2007 H.M. Singer